Rusted Seat Post

I picked up this old frame and the seat post is rusted to the frame.

I’ve tried many different things and was wondering if anyone had tips on how to get it out.

I’ve tried, knocking the outside of the seat post to free it up, lots and lots of WD40, twisting it, a friend tried the vice, car jack and a few other things.

Has this happened to anyone else? or does any one have any ideas on how I could get it out?


sheldon brown has a list of 15 things to try, search there

thanks, should have known sheldon would have it

the ‘last resort’ looks like the way to go

you might want to try and borrow a recipro saw off someone, doing it by hacksaw blade sounds like it would take many hours, although less chance of damaging the frame

I had this happen to me the other day. I banged the top of the seat post flat with a hammer and then used a big wrench to twist it a bit loose (using wd-40). That sort of worked but then I cut a small hole on either side of the seat post and put a metal bar through the holes, stood on either side of the bar and twisted and pulled the frame. you can get heaps of leverage this way, worked well.

Yeh, I tried drilling a hole in the post as well (I’m the friend mentioned above) but it’s too stuck even for that, bent about a thousand different poles. I’m letting it marinade in wd40 tonight then try all manner of twisting and pulling it

Materials? (Frame & post)

steel frame & aluminium post = NaOH bath to dissolve it.

steel frame & steel post = penetrene bath (not WD40, it won’t help) or gentle heating with a blowtorch

2nd last resort = hacksaw and collapse post.

Last resort = _uy a n_w ik (who wants to buy a vowel?)

When did B become a vowel? :wink:

I’d like to solve it thanks Larry.

B isn’t a vowel. But if you buy one it’ll help you eliminate ‘guy a now pike’

Adriana show Chromeo our range of fantastic prizes that he can choose from.
<theme music>

This happened to me the other week with a GT I was going to use for polo.

In the end I bought a new bike.

there’s a fair chance too that the wrong size post has been jammed in there at some point…